Intermittent Issues with Third-Party Apps
Incident Report for Nectir
Resolved
This incident has been resolved.
Posted May 14, 2020 - 13:57 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 14, 2020 - 13:39 PDT
Investigating
We are currently investigating issues with our third-party apps. Please contact our live chat service if you are unable to use them and we will resolve it for you ASAP.
Posted May 14, 2020 - 13:37 PDT
This incident affected: UCSB Nectir Workspace.