Investigating Version Update Bugs
Incident Report for Nectir
Resolved
This incident has been resolved.
Posted Sep 29, 2020 - 12:45 PDT
Investigating
We are monitoring a few bugs that appeared after our last version update. We will mark this incident as "resolved" as soon as said bugs are squashed.
Posted Sep 29, 2020 - 12:07 PDT
This incident affected: Nectir App.