Server down
Incident Report for Nectir
Resolved
This incident has been resolved.
Posted Apr 22, 2020 - 21:13 PDT
Update
The Google Cloud provider is having minor issues in a specific region. We are working with them to resolve the issue on our end.
Posted Apr 22, 2020 - 20:58 PDT
Update
We are continuing to investigate this issue.
Posted Apr 22, 2020 - 20:47 PDT
Update
We are continuing to investigate this issue.
Posted Apr 22, 2020 - 20:26 PDT
Investigating
We are experiencing increased load times. We are looking into the issue and will provide updates periodically.
Posted Apr 22, 2020 - 19:00 PDT
This incident affected: Nectir App.